🌕🌗🌑🌑🌑

# 題目連結

  • 題目連結
  • Online Judge
  • uDebug

# 題目說明

Time limit: 3.000 seconds

# 題目

The world-known gangster Vito Deadstone is moving to New York. He has a very big family there, all of them living in Lamafia Avenue. Since he will visit all his relatives very often, he is trying to find a house close to them.

Vito wants to minimize the total distance to all of them and has blackmailed you to write a program that solves his problem.

# Input

The input consists of several test cases. The first line contains the number of test cases.

For each test case you will be given the integer number of relatives r (0 < r < 500) and the street numbers (also integers) s1, s2, . . . , si , . . . , sr where they live (0 < si < 30000 ) . Note that several relatives could live in the same street number.

# Output

For each test case your program must write the minimal sum of distances from the optimal Vito’s house to each one of his relatives. The distance between two street numbers si and sj is dij = | si − sj | .

# Sample Input

2
2 2 4
3 2 4 6

# Sample Output

2
4

# 解題技巧

# Solution

Main.java
import java.util.*;
public class Main {
    public static void main(String[] args) {
        Scanner sc = new Scanner(System.in);
        int line = sc.nextInt();
        for (int i = 0; i < line; i++) {
            int family = sc.nextInt();
            int[] arr = new int[family];
            for (int j = 0; j < family; j++) {
                arr[j] = sc.nextInt();
            }
            Arrays.sort(arr);
            int num = arr[family / 2];
            int ans = 0;
            for (int j = 0; j < family; j++) {
                ans += Math.abs(arr[j] - num);
            }
            System.out.println(ans);
        }
        sc.close();
    }
}
單字

** **
!! !!

片語 & 搭配詞

!! !!