🌕🌑🌑🌑🌑

# 題目連結

  • 題目連結
  • Online Judge
  • uDebug

# 題目說明

Time limit: 3.000 seconds

# 題目

A sequence of n > 0 integers is called a jolly jumper if the absolute values of the difference between successive elements take on all the values 1 through n − 1. For instance,

1 4 2 3

is a jolly jumper, because the absolutes differences are 3, 2, and 1 respectively. The definition implies that any sequence of a single integer is a jolly jumper. You are to write a program to determine whether or not each of a number of sequences is a jolly jumper.

# Input

Each line of input contains an integer n ≤ 3000 followed by n integers representing the sequence.

# Output

For each line of input, generate a line of output saying ‘Jolly’ or ‘Not jolly’.

# Sample Input

4 1 4 2 3
5 1 4 2 -1 6

# Sample Output

Jolly
Not jolly

# 解題技巧

# Solution

Main.java
import java.util.*;
public class Main {
    public static void main(String[] args) {
        Scanner sc = new Scanner(System.in);
        while (sc.hasNextInt()) {
            int num = sc.nextInt();
            int[] arr = new int[num];
            int[] table = new int[num];
            boolean iSJolly = true;
            for(int i = 0; i < num; i++){
                arr[i] = sc.nextInt();
            }
            for(int i = 0; i < num - 1; i++){
                int tmp = Math.abs(arr[i] - arr[i + 1]);
                if(tmp >= num || tmp == 0){
                    iSJolly = false;
                    break;
                }else{
                    table[tmp]++;
                    if(table[tmp] > 1){
                        iSJolly = false;
                        break;
                    }
                }
            }
            System.out.println((iSJolly ? "Jolly" : "Not jolly"));
        }
        sc.close();
    }
}
單字

** **
!! !!

片語 & 搭配詞

!! !!